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Welcome to SysOrb knowledge base. Her you will find detailed explanation on questions regarding SysOrb. The list is under continues development and new articles will be added. You can follow the links below or enter a "key word" to search all of the articles.

SysOrb agent is not checking in to the Sysorb server

Symptoms: 

The SysOrb agent is not checking in to the SysOrb server and you have a red alert in the Checkin column in SysOrb webinterface.

In general the first thing to do is to look for the answer in the SysOrb agent log which can be found on the server where the agent is installed.
On windows the agent log is located in install-dir\Config\agent.log or it can be found in Start menu->Programs->SysOrb.

On unix the default location is

/var/log/sysorb/agent.log

Scroll down to the end of the log file to find the last log entry.
If one of the following similar log entry appears in the agent log then this article explain how to solve it.

Scenario 1:

Failed to register with server. Will try again in 28 seconds... (failures=8)
Reason given: "The SysOrb Server does not have a master key for the "node name" node in the "domain name" domain - release the key on the agent!"

Scenario 2:

Failed to register with server. Will try again in 28 seconds... (failures=8)
Reason given: "The SysOrb Server does not have a master key for the "node name" node in the "domain name" domain - release the key on the server!"
Cause: 

The first time the SysOrb agent contact the SysOrb server it will negotiate an encryption key with the server. This key will provide mutual authentication between the SysOrb Server and the SysOrb agent for all future communication. If one party loses the key, the two will be unable to mutually authenticate each other the next time the SysOrb Agent contacts the SysOrb Server.

If, for example, the Node is deleted from the web interface, the associated key is deleted on the SysOrb Server. In that situation, the key must be released on the corresponding SysOrb Agent to allow the two to negotiate a new key (scenario 1).

If, for example, the server on which the SysOrb Agent is running, is re-installed, the negotiated key will be lost on this system. In that situation, the key on the SysOrb Server must be released so that the SysOrb Server and SysOrb Agent can again negotiate a key (scenario 2).

Resolution: 

Release key on the agent (scenario 1)
On windows open the SysOrb configuration utility located in Start menu->Programs->SysOrb->SysOrb configuration. In the configuration tree choose SysOrb agent->General->Release Key. In the dialog on the right side of the configuration dialog click the Release Key button.

To release the agent key on a Unix-like system, you must delete the variables file while the SysOrb agent daemon is stopped. The location of the variables file is configured in the agent.conf file on the host where the agent runs usually:

/var/sysorb/variables.agent

Example:

/etc/init.d/soagent stop ; rm /var/sysorb/variables.agent ; /etc/init.d/soagent start

To release the agent key on a NetWare system, you must delete the variables file while the SysOrb agent NLM is unloaded. The location of the variables file is configured in the AGENT.CFG file on the host where the agent runs ususally:

\SYSORB\AGENT.VAR

Release Key on server side Scenario 2)
To release the key on server, do the following in the SysOrb web interface:

  • Click the Configure button in the navigation menu in SysOrb webinterface.
  • Find the host you want to have release the key for in the configuration tree.
  • Click edit on the edit link associated with the host.
  • Select Edit Node.
  • If the server and agent have negotiated a key you will be able to find a Agent key label. Click on the Release key on the right to release the key on the server. If the label is not present, it is because the server does not have a key for the host in question.

  • After you have released key on either SysOrb agent or SysOrb server wait a few minutes and observe. Now the agent should start to check in again.