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SysOrb agent stops checking in from a windows server with very long system uptime

Symptoms: 

On a Windows server with a very high system uptime(around 500+ days) the SysOrb agent suddenly stops checking in to the SysOrb server.

In the SysOrb agent log you see the following:

Reason given: "Error connecting: An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full. (10055)"

If you run a netstat on the server you get a very long list of TCP connections with the status "TIME_WAIT"

Cause: 

The root cause for this lies in the windows OS please relate to this Microsoft knowledge base article

Resolution: 

The recommended solution is to install all latest patches as is likely that hotfix is already present in one of them.
A simple reboot of the server will also clear all the time wait connections and the agent will start checking in again.